当前位置:首页框架资源LSPosed、EdXP框架

LSPosed、EdXP框架

注意:LSPosed与EdXp框架均需要基于Magisk安装,部分版本还需要安装Riru模块

模拟器安装Magisk教程:

Magisk框架下载与安装教程

目前模拟器推荐官方版25.2+25206的Magisk以及1.9.2的LSPosed,如果还没安装面具请在上面的文章内下载我们打包好的Magisk+LSPosed。

当然也可以使用狐狸面具(原德尔塔面具),新手推荐使用官方原版面具。

LSPosed框架 (支持安卓8.1~安卓14)

下载LSPosed

推荐Zygisk版本,面具开启Zygisk即可,无需额外刷入Riru模块,LSPosed自带隐藏属性。

2024年1月9日,因为某些原因,LSPosed团队已停止LSP更新维护(包括Shamiko等)

【123网盘】 LSPosed(包含历史版本与Riru)

提取码:pv9p复制
解压码:无

【百度网盘】 LSPosed(包含历史版本与Riru)

提取码:7sdf复制
解压码:无

官方开源地址:https://github.com/LSPosed/LSPosed

视频教程

LSPosed安装教程跟Magisk教程在一起,EdXP不建议用,参考即可

雷电模拟器版本:https://www.bilibili.com/video/BV1kv4y127af

夜神模拟器版本:https://www.bilibili.com/video/BV1Ud4y1T7U4

EdXPosed框架 (支持安卓8~11)

官方开源地址:https://github.com/ElderDrivers/EdXposed

需要刷入riru模块,面具不能开启Zygisk,EdXP无法隐藏。网盘已上传模拟器推荐使用的riru+edxp,装好就有APP

【123网盘】 EdXposed (需要Riru)

提取码:ghv3复制
解压码:无

【百度网盘】 EdXposed (需要Riru)

提取码:p2pc复制
解压码:无

Magisk Riru模块 (EdXp需要,LSP不推荐)

官方开源地址:https://github.com/RikkaApps/Riru

网盘下载在上面LSPosed文件夹里面有

基于Magisk刷入的框架的图文教程(所有Magisk面具模块都这样刷入)

注意,所有Magisk模块(压缩包)都是这样安装的,LSP、riru、edxp、shamiko都是

如果你使用的是Zygisk的LSPosed,需要先开启Zygisk,如果不是就不要开启,Zygisk会跟riru冲突,edxp就不能开

LSPosed、EdXP框架

(使用Zygisk版LSPosed需要开启面具设置里面的Zygisk)

 

LSPosed、EdXP框架

 

“每个模拟器的共享目录不一样,但是都大同小异,反正放在共享目录里,你在模拟器里面能找到你放的文件就行”

然后侧边栏打开共享目录,将模块放在共享目录里面,在打开面具右下角的模块,安装模块

LSPosed、EdXP框架

LSPosed、EdXP框架

LSPosed、EdXP框架

LSPosed、EdXP框架

LSPosed-Zygisk版只需要刷入这一个模块即可,edxp和LSPosed需要再刷入一个Riru模块。

刷入完成后重启即可,如果桌面没有出现图标的话,可以下拉通知栏进入,也可以解压这个压缩包在里面找到一个Manager类似的apk拖进模拟器,桌面就有图标了

LSPosed、EdXP框架


给小白和一些刚开始了解面具的人讲一下,面具和这些框架到底有什么用。其实面具主要功能就两个,一个是管理root权限,并且可以隐藏,因为模拟器自带的root是没有隐藏这个功能的,而面具就可以隐藏,但是截止教程发布的时候,经过我们的测试,无论是官方版还是德尔塔之类的修改版,在模拟器上都还没法对所有app完美的隐藏root。所以也不是说做了隐藏就一定能对所有的app都隐藏,这个需要自己去针对性的测试才行,凡事没有那么多绝对的。然后另一个就是安卓8以上的模拟器,安装框架需要用到面具,因为安卓8以上只能用edxp和lsp,这两个xp框架都是依赖面具的,只有原生xp,也就是安卓5和7用的,不需要依赖面具只需要root就行了。所以在安装之前,先确认自己的需求,如果你是为了用xp模块,那就肯定要用框架,如果你用不上xp模块,只是用root权限,就只需要安装面具然后做隐藏就行了,就不需要去装框架,因为装了也没什么用反而会被检测或者说造成不必要的性能浪费

然后说一下这三个框架的区别,他们本质上都是xp框架,只是支持的安卓版本不同,原生XP只支持部分安卓8及以下的系统,edxp和lsp就支持安卓8以上。
也就是说,安卓5、安卓7、安卓7 64位,想用模块直接装原生xp框架就行了,也装不了edxp或者lsp。安卓9的话,装不了原生xp,只能装lsp或者edxp,然后这两个框架怎么选择有什么区别也讲一下,edxp主要是原生xp的升级版,依然是全局生效,然后不带隐藏,LSP就是edxp升级而来,多了一个作用域的功能,可以隐藏,作用域就是说,比如你安装了两个app。模块只需要给其中一个生效,那用LSP就可以实现只对一个app生效,如果是用edxp的话,全局生效,一个是会让系统整体稍微变卡一些,因为所有app都被框架拦截了,lsp就只会对你选择的应用生效,隐藏性和稳定性要强一些,但是如果有些很老旧的模块或者模块本身就需要全局生效的,可能就只支持edxp,虽然目前还没遇到几个,但是也不排除有,到时候可以自己测试一下

LSPosed、EdXP框架

温馨提示:

文章标题:LSPosed、EdXP框架

文章链接:https://www.duokaiya.com/lsposed.html

更新时间:2024年02月14日

本站大部分内容均收集于网络!若存在内容侵权等问题,请发送邮件至:admin@duokaiya.com我们将第一时间处理!

资源所需价格并非资源售卖价格,是收集、整理、编辑详情以及本站运营的适当补贴。

所有资源仅限于参考和学习,请在下载后24小时内删除,版权归原作者所有。

0 条回复 A文章作者 M管理员
    暂无讨论,说说你的看法吧
个人中心
购物车
优惠劵
今日签到
搜索
'